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Part A – Coversion of PDB file into VMD representation 

1 Download the PDB file with accession code 2zu5 from 
the PDB database. 

 

2 In the 2zu5 PDB page, find the name of the ligand.  For 
2zu5, the ligand is named Zu5. 

 

3 Manually erase all heteroatoms and any chains other 
than chain A.  Name the file 2zu5_ProteinChainA.pdb 

 

4 
Upload the file 2zu5_ProteinChainA.pdb to 
http://sysbio.rnet.missouri.edu/3Drefine/  
 
Save the output file 2zu5_3DrefineOutput.pdb 

 

 

http://sysbio.rnet.missouri.edu/3Drefine/


5 
Upload 2zu5_3DrefineOutput.pdb to the following 
website https://playmolecule.org/proteinPrepare/  
 
Save the output file as 
2zu5_ProteinPrepareOutput.pdb 

 

 

6 

Upload the file 2zu5_ProteinPrepareOutput.pdb into 
VMD and find an atom within the active site which will 
serve as the center of the sphere within which Hollow 
will fill dummy atoms.  Also upload the original 
2zu5.pdb file and display the ligand Zu5.  Choose an 
atom that sits “above” the active site.  For 2zu5, I 
chose the atom with index 2208 which belong to ASN 
which resembles a “faucet” above the “sink” of the 
active site.  Record the name, resid, and chain.  For 
2zu5, these values are ND2, 142, A. 

 

7 Copy the file 2zu5_ProteinPrepareOutput.pdb to the 
Hollow directory. 

 

8 
Open the hollow.txt file and set the following variables 
to the values 
                                   grid_spacing: 0.2 
                                   interior_probe: 1.2 
                                   surface_probe: 8.0 

{ 
  'grid_spacing': 0.2, 

  'interior_probe': 1.2, 
  'surface_probe': 8.0, 
  'bfactor_probe': 0.0, 

  'res_type': 'HOH', 
  'atom_type': 'O', 

  'atom_field': 'ATOM', 
  'is_skip_waters': True 

} 

9 
Open the constraints.txt file.  Set the 
remove_asa_shell to True, chain1 to A, res_num1 to 
142, and atom1 to ND2. 

{ 
  'remove_asa_shell': True, 

  'type': 'sphere',  
  'radius': 20.0,  
  'chain1': 'A',  

  'res_num1': 142,  
  'atom1': 'ND2',  

} 

1
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Press the Windows and R keys simultaneously 

 

1
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In the window that opens, type cmd then press OK 

 

https://playmolecule.org/proteinPrepare/


1
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In the window that opens, navigate to the hollow 
directory 

 

1
3 

Issue the following command  
C:\Python27\python.exe hollow.py -c constraint.txt -o 
2zu5_HollowOutput.pdb 
2zu5_ProteinPrepareOutput.pdb 

 

1
4 

Copy the file 2zu5_HollowOutput.pdb to the working 
directory 

 

1
5 

Copy the coordinates of Zu5 into the file 
2zu5_ProteinPrepareOutput.pdb and save as 
2zu5_HollowAndLigandAdded.pdb 

 

1
6 

Copy the coordinates of the hollow generated water 
molecule oxygen atoms from 2zu5_HollowOutput.pdb 
into the file 2zu5_HollowAndLigandAdded.pdb 

 

1
7 

Use the script 
01_BfactorPharmacophoreColorCoding.pl to modify 
the B-factor column of the file 
2zu5_HollowAndLigandAdded.pdb and name it 
2zu5_B-FactorModified.pdb 

 

1
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In the VMD console, issue the following commands 

proc tricolor_scale {} { 
  set color_start [colorinfo num] 

  display update off 
  for {set i 0} {$i < 1024} {incr i} { 

    if {$i == 0} { 
# Hydrophobic --> Gray --> 1.00  

      set r 0.60;  set g 0.60;  set b 0.60 
    } 

    if {$i == 128} { 
# Aromatic --> Cyan --> 2.50 

      set r 0.25;  set g 0.75;  set b 0.75 
    } 

    if {$i == 256} { 
# Polar --> Green --> 3.50 

      set r 0;  set g 1;  set b 0 
    } 

    if {$i == 384} { 
# Hydrogen bond acceptor (HBA) --> Violet --> 4.50 

      set r 0.65;  set g 0.0;  set b 0.65 
    } 

    if {$i == 512} { 
 

# Hydrogen bond donor (HBD) --> Orange --> 5.50 
      set r 1;  set g 0.5;  set b 0 

    } 
    if {$i == 640} { 

# Water molecule oxygen atom (HBA) --> Magenta --> 6.50 
      set r 1;  set g 0;  set b 0.66 

    } 
    if {$i == 768} { 

# Water molecule hydrogen atom (HBD) --> Ochre --> 7.50 



      set r 0.50;  set g 0.30;  set b 0 
    } 

    if {$i == 896} { 
# Anchor --> Red --> 9.00 

      set r 1;  set g 0;  set b 0 
    } 

    color change rgb [expr $i + $color_start     ] $r $g $b 
  } 

  display update on 
} 
 

tricolor_scale 

 

1
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Open the file 2zu5_B-FactorModified.pdb in VMD.   
 
A) render the portion of the protein surface that is 
within 9 angstroms of the ligand Zu5 and color 
iceblue. 
 
not (resname ZU5 or waters) and same residue as 
within 9 of resname ZU5 
 
B) render hollow generated water molecule oxygen 
atoms as points and size 20.  Select for occupancy 1. 
 
C) make a third rendering which is the same as (B) but 
with oxygen atoms colored blue and within a distance 
X from point Y.   

 
 

 

2
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Through a process of trimming, select a point (Y) which 
is far from the active site and next to other points that 
you wish to eliminate.  Then try out different distances 
(X) from point (Y) which capture as many points as you 
wish to eliminate while not bleeding into the points 
that belong to the active site.  When you have found a 
satisfactory X and Y, then issue the following 
commands in the VMD console; 
 
set sel [atomselect top "water within X of index Y"] 
$sel moveto {0 0 0} 
 
Make sure that blue dots do not invade or seep into 
the active site red dots.  If they do, then points 
defining the active site might be lost.  You might want 
to use Extensions → Visualization → Clipping Plane 
Tool and check the box for Normal follows view in the 
window that pops up in order to check that no blue 
dots infiltrate the red dots in the active site. 
 

 

 

2
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When trimming is complete on the oxygen atoms 
representing the active site, do the following; 
 
a) Show the oxygen atoms representing the active site 
as a QuickSurf with the following parameters; 

 



        
       i) Radius Scale: 0.3 
      ii) Density Isovalue: 0.1 
     iii) Grid Spacing: 0.5 
     iv) Surface Quality: Max 
      v) Material: Transparent  
 
waters and occupancy 1 and not (x = 0 and y = 0 and z 
= 0) 
 
b) Display → Orthographic 
c) Display → Axes → Off 
d) Extensions → Visualization → Ruler 

2
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Translate the structure so that the active site is at the 
crosshairs of the ruler.  Make sure that no part of the 
structure, except for the surface defining the 
“bottom” of the active site, crosses over the vertical 
axes of the ruler. 

 

2
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In the tcl console, issue the following command; 
rotate x by 90 

 

2
4 

Note the grid size at the bottom left corner of the VMD 
window 

 

2
5 

Save the visualization state in VMD as 
2zu5_PreSegmentationVisualizationState.vmd 

 

2
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File → Render 
In the File Render Controls window that opens, select 
Wavefront (OBJ and MTL) from the Render the 
current scene using: dropdown window.  Select a 

 



directory to save the rendered file then save the file as 
vmdscene.obj.  Press Start Rendering 

2
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Import the file vmdscene.obj into Blender 

 

2
8 

Export the file untitled.obj out of Blender 

 

2
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In Blender, go to Granite Pencil → Ruler/Protractor 

 

3
0 

Measure the distance of one side of the grid.  Here it 
is measured to be 0.605855 

 
Part B – Segmentation of VMD representation 

3
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Open the file 02_SegmentCreator.pl and modify the 
following parameters; 
 
$PrjNme – project name 
$WrkDir – working directory 
$ImgNme – image name 
$MolIdn – VMD mol identifier 
$VmdDst – VMD distance (typically this is 10 
angstroms) 
$BldDst – Blender distance  
 

 
 

 

3
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Run the script 02_SegmentCreator.pl 

 

3
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Open the file 03_ContourCreator.pl and modify the 
following parameters; 
 
$MaxNumLne – maximum number of segments 
$BseFleNme – base file name 
 

 



3
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Run the script 03_ContourCreator.pl 

 

3
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Open the file: 
UnFlattenedContour_2zu5_SARS_3CL_protease.xyz 

 

3
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Open a tcl command window and copy and paste the 
following into the window: 

color Display Background white 
color Element He cyan2 
color Element Cl green2 
color Element Na purple 
color Element P orange2 
color Element K violet2 
color Element Ti gray 

color Element Md magenta 
color Element B iceblue 
color Element S yellow 

color Element Ga magenta 
color Element Ge red 

color Element As orange 
color Element Se blue 

color Element Br green 
color Element Kr black 

axes location off 
display depthcue off 
display nearclip set 0 
display farclip set 100 

display projection orthographic 

3
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Display all and not element O B as points with size 5 
and color by element 

 



3
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In the Tcl console, issue the following commands; 
 
rotate y by 180 
rotate x by 90  
 
The side having dots which are colored red should be 
to your left and the side having dots which are colored 
blue should be at the top of the screen. 

 

3
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Create another representation displaying element C in 
VDW and with sphere scale of 0.2 

 

4
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Create another representation displaying element Cs 
in VDW and with sphere scale 0.2.  Color this atom red. 

 

4
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Create another representation displaying element B 
as points of size 2 

 

4
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Scale the scene so that the dots fill up as much of the 
screen as possible while still showing all of them 

 

4
3 

Copy the contents of the file: 
2zu5_SARS_3CL_protease.VMDclippingCommands.tx
t and past it into the Tcl console. 

 

4
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Review each contour and determine which ones will 
be cut and which ones will be discarded.  For this 
model of 2zu5, the segments which are chosen are 23-
78.  Save these segment images in a separate folder 
for convenience 
 

 

Part C – Preparing segments for cutting 



4
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Open InkScape.  Navigate to File → Document 
Properties 
 
1. Under the “Page” tab: 

a) Change “Default units:” to inches (in). 

b) Change the “Units:” to inches (in).  In the “Custom 
size” window, choose a  
“Width:” of 48 inches and a “Height:” of 48 inches.  

c) Under “Display” click on “Show border shadow”  

2. Under the “Grids” tab,  
 
a) Press the “New” button  
b) Change “Grid units:” to inches (in).   
c) Make “Spacing X:” 1.0 and “Spacing Y:” 1.0 

  

 

4
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Note the length of each side.  For this work, each side 
is 39 points wide. 

 

4
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Unclick the snap to grid icon on the left sidebar 

 

 

4
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Navigate to “File” → “Import” then find a segment to 
import.  Press on the lock icon at the top.  Expand the 
image until it is the same scale as InkScape.  Determine 
the width and height.  Record these values because 
they will be applied to all subsequent image imports     

 



 

 

4
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Click on the letter icon on the left.  Create the letter 
“L”, size it to 100, then color it red.  Click on the letter 
“L” then navigate to “Path” → “Object to Path”.  This 
will serve as the orientation, center, and angle marker 
for each segment. 

 

 

5
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Click on the star/pentagon icon on the left side.  
Ensure that the shape is a pentagon by clicking on the 
pentagon icon at the upper left corner.  For the “Fill 
and Stroke” window and under the “Fill” tab, click on 
“No paint”.  Under the “Stroke paint” tab, click on 
“RGB” and set “R” to 250.  Then click on “HSL”.  For the 
first segment, set the “H” value to 0.  Use increments 
of 15 to identify subsequent segments.    

5
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Click on the pencil icon on the left.  Trace a path of the 
colored portions of the contour.  Make sure that the 
contour goes through the pentagon shape.  

 

5
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Select both the pentagon shape and the traced 
contour 

 



5
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“Path” → “Union” then “Path” → “Simplify” 

 

5
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Click on the “Edit paths by node” icon 

 

5
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Select points to eliminate.  Eliminate these points by 
clicking the “Delete selected nodes” icon at the upper 
left corner 

 

5
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Arrange points for the easiest cutting 

 

5
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Copy the marker letter “L” and place is so that the 
corner of the letter “L” is at the dot which is colored 
magenta. 

 

5
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Erase the original image 

 

5
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Group the letter “L” and the contour 

 



6
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Place the contour in the bounding box 

 

 
“File” → “Export PNG Image…” 

Under “Image size”, change “Width” to 2400 and change “Height” to 2400 then click on “Export” 

6
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Open 
FlattenedContour_2zu5_SARS_3CL_protease.xyz 
Extensions → Visualizations → Grid 

File → Render… 
--res 300 --format tiff 

 

  

 

 Filters → Image Effects → Sharpen More 

 



  

 

 
Add a rectangle around the image 
Select both the original image and the rectangle  
Object → Clip → Set 
File → Export PNG Image … 

 
 

 

 

 

 

 


